Blog Upgraded to 2.0.4

By | 2006 年 08 月 02 日

Grrr~~~

没有想到这次升级Blog居然会如此费尽周折:
晚饭听雨的时候决定把WP升级到2.0.4,因为旧版WP中存在严重的漏洞。庆幸的是,我似乎预见到这次升级不会太太平,因此花了很长的时间去备份网站的数据库和文件等。这没有难点。

问题的出现在我习惯性的覆盖上传文件后访问网站出现错误提示。会不会是因为FlashFXP上传的时候对某些文件不是采用的覆盖而是续传?忐忑不安中把首页换成了“网站维护中”的提示,然后把所有WP相关的旧文件删除,队列完新文件,就撤回宿舍了。到了宿舍我并不能很快的上网,因为电脑被同学占用着。所以拾掇拾掇后才得以上网。

Blog依然是那样的提示,让人觉得无望。突然觉得自己升级的步骤有问题:自己应该把相关的插件停用,把主题换成默认模板,等升级无误后再依次激活插件,以减少插件对新程序不兼容所可能带来的影响。所以,有了思路后就好办了:导出原有插件,再删除所有插件内容,后运行升级程序,依次查找错误。果然,升级成功,并成功进入后台;尽管暂时首页无法访问,在后台设置为默认模板后一切正常。

在排除Blog不能正常工作的时候,意外的发现,所以外调的.mo语言包都会导致第一次升级是所出现的错误。没有办法,只等把所有.mo文件都删除。然后激活常用插件,切换回现有主题,一切正常。

.mo文件调用错误的问题改日找找看其他朋友有没有什么好的方子,至少这会我是不行了。困了,啊~~

发表评论

您的电子邮箱地址不会被公开。